廣州暨華電腦學校
咨詢熱線:020-85566216

誠        毅        精      勤

當前位置:所在位置: 廣州電腦培訓 >> 電腦技術 >> network >> 正文

虛擬路由器冗余性協議--VRRP

發布時間:2018/2/26 15:39:25 內容來源::廣州暨華電腦學校 點擊:

VRRPVRRP(虛擬路由器冗余性協議)
在一個HSRP或VRRP組中,選舉出一臺路由器來負責處理發送到虛擬IP地址的所有請求
在HSRP中,這臺路由器稱為活躍路由器。一個HSRP組中有一臺活躍路由器、一臺備用路由器、可能有很多臺監聽路由器。而一個VRRP組中有一臺主用(master)路由器,以及一臺或多臺備用(backup)路由器。
HSRP與VRRP之間的比較
 
HSRP
   
VRRP
HSRP屬于cisco私有協議
VRRP屬于IEEE標準協議(開放式)
最多支持16個組
最多支持255個組
1個活躍路由器、1個備份路由器、若干個監聽路由器
1個活躍路由器、若干個備份路由器
虛擬IP地址與活躍路由器和備用路由器等的真實IP地址不同
虛擬IP地址可以與其中一個組成員的真實IP地址相同
使用224.0.0.2發送hello數據包
使用224.0.0.18發送hello數據包
默認計時器:hello時間3秒,保持時間10秒
VRRP中的默認計時器小于HSRP。從而使VRRP故障倒換速度快于HSRP。
可以追蹤接口或對象
只可以追蹤對象
默認在每個組中使用認證。當管理員沒有對認證進行配置時,默認以cisco為密碼進行認證
支持明文認證和HMAC/MD5認證方式。
VRRP的冗余性
Ø  VRRP可以為路由器真實IP地址提供冗余性,或者也可以為VRRP組成員共享的虛擬IP地址提供冗余性。
Ø  如果管理員使用了真實IP地址,那么配置了該地址的路由器就會成為主用路由器。如果管理員使用了虛擬IP地址,那么具有最高的優先級成為主用路由器。
Ø 一個VRRP組中有1個主用路由器,以及一個或多個備用路由器。主用路由器使用VRRP消息來通知組成員它的主用角色。

VRRP的優先級
對于將VRRP組IP地址設置為某個組成員物理接口IP地址,擁有該IP地址的路由器將成為該組的主用路由器。它的優先級設置為255.備用路由器的優先級范圍可以使1-254,默認值為100。優先級值0有特殊意義,它表示當前的主用路由器以不參與VRRP的運作。這個設置可以用來觸發備用路由器快速過渡到主用模式,而無需等待當前的主用路由器超時。

VRRP計時器
當主用路由器變為不可用時,VRRP中的動態切換機制會用到三個計時器:公告間隔、主用失效間隔時間、時滯時間。
Ø  公告間隔:是指主用路由器發送公告消息的時間間隔(秒為單位)。默認間隔為1秒。
Ø  主用失效間隔:是指備用路由器認為主用失效的時間間隔(秒為單位)。默認間隔是時間的計算方式為3 x 公告間隔 + 時滯時間
Ø 時滯時間:計算方式為(256- 優先級/256)毫秒,它確保了具有最高優先級的備用路由器成為新的主用路由器。

注意:
    在VRRP主用路由器正常關機的案例中,它會以優先級0發送公告信息。這個優先級設置會觸發備用路由器快速接管主用路由器的工作,只需等待時滯時間,而無需等待主用失效間隔時間。
   HSRP和VRRP最主要的區別在于,VRRP中的備用路由器不發送公告信息,因此VRRP主用路由器無法感知當前的備份路由器
VRRP配置案例
拓撲圖:

實驗思路:
1、sw1、sw2、sw3個相連的端口配置為trunk
2、在每臺交換機中添加vlan 10
3、將sw3的f0/0端口加入到vlan10中
4、在sw1和sw2中配置SVI虛接口,并配置VRRP
5、配置host1將默認網關指向vrrp配置的虛擬IP
6、驗證主用路由器down后,host1還能正常訪問網絡

1、
SW1(config)#doshint trunk
Port     Mode         Encapsulation  Status       Native vlan
Fa0/0    on           802.1q         trunking      1
Fa0/1    on           802.1q         trunking      1
---------------------------------------------------------------------
SW2(config)#doshint trunk
Port     Mode         Encapsulation  Status       Native vlan
Fa0/0    on           802.1q         trunking      1
Fa0/1    on           802.1q         trunking      1
---------------------------------------------------------------------
SW3(config)#doshint trunk
Port     Mode         Encapsulation  Status       Native vlan
Fa0/1    on           802.1q         trunking      1
Fa0/2    on           802.1q         trunking      1

2、
SW1#vlandatabase   ---進入vlan數據庫中配置vlan(這個屬于舊配置方法)
SW1(vlan)#vlan 10    ---添加vlan 10
VLAN 10 added:
   Name: VLAN0010
SW1(vlan)#exit      ---退出并保存配置
APPLY completed.
Exiting....
SW1#
---------------------------------------------------------------------
【sw2和sw3上的配置與上述配置相同】

3、
SW3(config)#int f0/0----進入f0/0接口
SW3(config-if)#switchport mode access    ---將該接口配置為access模式
SW3(config-if)#switchport access vlan 10 ---將該接口加入到vlan  10中
SW3(config-if)#exit
SW3(config)#  
SW3(config)#do shvlan-s
VLAN Name                             Status    Ports
---------------------------------------------------------------------
1   default                         active    Fa0/3, Fa0/4, Fa0/5, Fa0/6、Fa0/7, Fa0/8, Fa0/9, Fa0/10、Fa0/11, Fa0/12,Fa0/13, Fa0/14、Fa0/15
10   VLAN0010                         active    Fa0/0

4、
虛接口的配置:
SW1(config)#do shrun int vlan 10
Building configuration...
Current configuration : 63 bytes
!
interface Vlan10
ip address 192.168.10.1255.255.255.0
end
SW1(config)#
---------------------------------------------------------------------
SW2(config)#do shrun int vlan 10
Building configuration...
Current configuration : 63 bytes
!
interface Vlan10
ip address 192.168.10.2255.255.255.0
end
SW2(config)#
VRRP的配置:
SW1(config)#do sh run intvlan 10
Building configuration...
Current configuration : 119 bytes
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
vrrp 10 ip 192.168.10.254  ---在接口上啟用VRRP,該命令使接口成為使用這個虛擬IP地址的虛擬組的成員;10代表組號、192.168.10.254代表此VRRP組使用的IP地址(可以為虛擬IP也可以為其真實的物理IP地址)
vrrp 10 timers advertise msec 500 ----更改計時器,計時器參數指明設備作為主用主用路由器的公告間隔。(這里為500毫秒)
vrrp 10 priority 200    ----設置VRRP組此臺路由器的優先級;具有最高的優先級為主用路由器。如果多臺路由器的優先級相同,那么具有最高真實IP地址的網關通過選舉成為主用路由器。
end
SW1(config)
---------------------------------------------------------------------
SW2(config)#do sh run intvlan 10
Building configuration...
Current configuration : 134 bytes
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
vrrp 10 ip 192.168.10.254
vrrp 10 timers learn   ----的意思就是從主路由器那里獲悉VRRP通告時間間隔,一般是從路由器才這樣配置的
vrrp 10 priority 150
end
SW2(config)#
驗證:
 
SW1(config)#do  shvrrp brief
 
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
 
Vl10               10  200 1718       Y   Master  192.168.10.1    192.168.10.254
 
SW1(config)#
 
SW2(config)#do  shvrrp brief
 
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
 
Vl10               10  150 3414       Y   Backup  192.168.10.1    192.168.10.254
 
SW2(config)#
5、

6、
將sw1的vlan 10(或f0/1口)給shutdown掉
SW1(config)#intvlan 10
SW1(config-if)#shutdown
---------------------------------------------------------------------
再使用host1的ping測試:(pingsw2能夠ping通,而sw1無法ping通)

 

學校簡介 |專業課程 | 學生就業 | 參觀學校

學校地址:廣州天河區五山路金華園區C座3樓307(華南理工大學南門旁)

學校名稱:廣州暨華電腦培訓學校 聯系電話:020-85566215

2002-2019 廣州青大教育信息咨詢有限公司 版權所有 備案/許可證編號為:粵ICP備11083420號-11

今天30选5开奖公告